Advanced features

Developer tools

Opera includes several tools to aid web developers:

  • Opera Next – a parallel build of Opera, with cutting-edge features
  • Opera Dragonfly – a complete developer toolkit that also enables remote debugging of webpages
  • Error console – an error-reporting tool for webpages rendered by Opera
  • Source viewer – a simple tool for examining the source code of a webpage, and making quick changes.

Error console

What is the error console?

The error console reports errors that Opera encounters while rendering webpages. To avoid confusion, it is necessary to distinguish between two similar features:

In Opera: The error console
From the Opera main menu, select View > Developer Tools > Error Console.
In Opera Dragonfly: The Errors panel
In Opera Dragonfly, select the Errors panel

In summary, the difference is that the Errors panel in Opera Dragonfly provides better context, but it only begins reporting errors after Opera Dragonfly is opened, while Opera’s error console is the better choice when you require complete error reporting from the time that the browser is first opened.

Kiosk mode

Kiosk mode is designed for system administrators and takes advantage of full screen mode to present users with a limited version of the browser, for example, for use in schools, libraries, or public information kiosks. Opera can be started with the command line switch -kioskmode.

Dragonfly

What is Opera Dragonfly?

Opera Dragonfly is a tool for developing and debugging local and remote webpages. It includes a DOM view of webpages and highlighting of elements. You can step through your JavaScript code, and quickly inspect changes to your CSS styles. You can debug your extensions and widgets, and study your application’s impact on network resources.

One of the standout features of Opera Dragonfly is remote debugging. Remote debugging makes it possible to debug webpages as seen on a mobile phone or a television from your desktop.

The complete list of features in Opera Dragonfly is too long to detail here. For more information, see the following pages:

Opera Dragonfly is implemented as a web application, and updates occur automatically as soon as they are posted to the server. The application is open source, with an Apache 2.0 license.

How do I open Opera Dragonfly?

To open Opera Dragonfly, take one of the following steps:

  • Ctrl-click an element of the page, and select “Inspect Element” from the context menu.
  • From the main menu, select View > Developer Tools > Opera Dragonfly.
  • Use the keyboard shortcut Command (⌘) + Option (⌥) + I or Ctrl + Shift + I.

How do I close Opera Dragonfly?

To close Opera Dragonfly, take one of the following steps:

    • Click the close icon (“X”) on the upper right side of the Opera Dragonfly window.
    • From the main menu, uncheck View > Developer Tools > Opera Dragonfly.
    • As when opening, use the keyboard shortcutCommand (⌘) + Option (⌥) + I or Ctrl + Shift + I.
  • When the Opera Dragonfly window has focus, use the keyboard shortcut  + W or Ctrl + W, as with any other tab.

Opera Next

What is Opera Next?

Opera Next is a parallel build of Opera, with cutting-edge features. It is useful especially to developers and testers. You can install it and run it independently of your primary version of Opera; the two do not mix. To avoid confusion, Opera and Opera Next are distinguishable by their appearance:

  • Distinct application icons
  • “Opera Next” instead of “Opera” as the menu header

but it is the difference in behavior that truly distinguishes Opera Next:

By default, Opera Next is auto-updated every time a new snapshot appears on the Opera Desktop Team blog, including all of the alphas and betas released by Opera. To slow down the release cycle, so that you only get alphas and betas, but not all the snapshots from the Opera Desktop Team, unselect the option DownloadAllSnapshots, and save the setting.

Snapshot Alpha Snapshot Beta Snapshot RC Final
Opera Next (with snapshots) X X X X X X X
Opera Next (no snapshots) X X X
Opera X

For stable day-to-day browsing, use Opera; to experiment with the latest and greatest features, use Opera Next.

Server settings

Server name completion

When you enter a single word (for example “opera“) in Opera’s address field, Opera will:

  1. Look for a bookmark nicknamed “opera
  2. Search using your default search engine for “opera”

When you enter a single word in Opera’s address field, followed by a forward slash (for example “opera/”), Opera will:

  1. Look for a computer in your local network called “http://opera/”
  2. Attempt server name completion by adding prefixes (such as “www”) and suffixes (for example “com”) to look up “www.opera.com”

You can enter comma-separated lists of prefixes and suffixes. You may for example want to add the top-level domain of your home country to the list of suffixes.

Note: It takes time to try multiple combinations; if your connection is slow, you may want to turn this feature off for faster browsing.

Tip: To skip directly to server name completion by prefix and suffix, press +Enter or Ctrl + Enter.

Proxy servers

A proxy server is a computer that can, for example

  • Store local copies of webpages so that a group of people (such as employees or subscribers) can get quick access to often-visited webpages
  • Act as an interpreter between your browser and a special service
  • Alter or monitor information exchange
  • Speed up internet communication

To change your proxy server, go to Preferences > Advanced > Network, click Proxy serversand enter the necessary information. All traffic using the respective protocol will now go through the proxy server you specify.

To use a proxy, you need to specify:

  1. A protocol (such as HTTP)
  2. An internet address (such as proxy.example.org or 192.0.34.166)
  3. A port number (such as 5000)

You can get this information from your internet service provider (ISP), the host of your proxy server, or the documentation that comes with your proxy software.

You can specify whether you want the proxy used even for local servers by checking the “Use proxy for local servers” checkbox.

To access certain sites without going through the proxy, you can enter a list of web addresses to exclude. See: Bypassing proxy servers: Exception List below.

If your internet provider requires automatic proxy, please enter the web address provided by your ISP.

Adding proxy servers manually

Your service provider or network administrator should have provided you with the necessary server names and port numbers. If not, please contact the appropriate party and ask them for this information.

These are the supported proxy protocols:

  • HTTP: for HTTP servers (ordinary websites)
  • HTTPS: for secure documents (use only when behind a firewall)
  • FTP: for FTP files
  • Gopher: required if you want to access gopher servers
  • WAIS: required if you want to access WAIS servers
  1. Go to Preferences > Advanced > Network, and click Proxy servers.
  2. Tick the checkboxes for the protocols you want to use a proxy for, and enter the proxy server hostname or IP address in the text field to the right of the protocol name (HTTP, HTTPS…). To the right of the protocols there is a box available for the port number.
    [v] HTTP [ proxy.proxyexample.com ] Port [8080]

    or

    [v] HTTP [ 123.45.67.89         ] Port [8080]

Bypassing proxy servers: Exception List

You can specify which servers should be accessed directly and not through the proxy by adding them to an exception list. For example, you may want to do this if a server is so close that the proxy would be a bottleneck even if it had the document stored locally. Just click theException List button, select the option “Use proxy for all servers except those on the list”, and add one server or host per line, like this:

*.opera.no
www.opera.com

This tells Opera that the *.opera.no domain and the www.opera.com server should be accessed directly and not routed through the proxy. As the example shows, wildcards can be used. You can also separate entries by using a comma or semicolon instead of putting each one on a separate line.

Conversely, you can set up a whitelist of servers that should be routed through the proxy, by selecting the option “Only use proxy for servers on the list”. Normal traffic will not use the proxy.

Automatic proxy configuration

For automatic proxy configuration, click the radio button for “Use automatic proxy configuration” and enter the address (URL) to the automatic proxy configuration script in this field.

Encode international web addresses with UTF-8

Some servers may prefer that Opera encodes the address in local character encoding (like latin-1) instead of the recommended UTF-8 encoding. Set these preferences at Preferences > Advanced > Network.

You enter http://www.example.org/æøå.html
Address in latin-1 http://www.example.org/%E6%F8%E5.html
Address in UTF-8 http://www.example.org/%C3%A6%C3%B8%C3%A5.html

Max connections to a server

It is recommended to keep the default setting of 16, but you can try changing the maximum number of connections to a single server if you are experiencing problems with browsing speed.

Max total connections

It is recommended to keep the default setting of 64, but you can try changing the maximum number of connections to all servers if you are experiencing problems with browsing speed.

Source viewer

What is the source viewer?

The source viewer is a simple tool for analyzing and modifying webpages. If you want to have a look at the source code of the current webpage, take one of the following steps:

  • Right-click (or Ctrl-click) the page and select “Source”
  • From the menu, go to View > Developer Tools > Source
  • Use the keyboard shortcut  + U or Ctrl + U

The source viewer opens in a new tab on your tab bar, and it has syntax highlighting to give you a better overview of the source. It is not just a viewer, but also an editor, and allows you to make changes to the page. It may surprise you to learn that you can make changes to the page (temporarily), even if it is not on your computer! If the page is on your computer, changes to the page are applied permanently. If not, changes to the page are applied only in cache, and reloading the page will reset it to its original state.

The source viewer includes two buttons for modifying and saving the page:

  • Apply Changes – Once you have edited the source, this button applies the changes to the page
  • Save – This button saves the (possibly modified) page source to a location of your choice

If you prefer to use an external program for source viewing and editing, you can specify it in the programs preferences.

Storage

Offline applications

The idea of Offline Applications is to make your favorite online services, such as web mail, available even when you are offline. Naturally in this situation you will not be able to send mail, but you should be able to read your old messages, and compose new messages that will be sent when you come back online.

To use a website when offline, you need to have access to many of its resources, including the HTML, CSS, and JavaScript that form the layout and functionality of the page, not to mention the data relevant to your account — in the case of a site that provides web mail, that includes your messages. The necessary browser infrastructure is provided by the following specifications:

of which the first two pertain to data storage, and the last to the resources that make up the layout and functionality of the website. A website that applies these specifications will make its resources available to you when you are online, and they will be saved to your computer.

Notice that the browser infrastructure required for offline applications is useful not just when you are offline, but also when you are online, because it lessens the need for contact with the server. Offline applications speed up online browsing, in much the same way as cache does.

Storage preferences

Preferences > Advanced > Storage

Webpages using persistent storage

You can manage the list of websites that store information on your computer, according to the above specifications. Select a website and press “Delete” to delete the data and resources connected with that site. Click “Clear All” to delete the resources connected with all sites.

Use application cache

The default setting is “Yes”, and since application cache is useful both when you are online and when you are offline, you may want to leave it. Choose “No” to disable caching of website resources, and “Ask me” if you want each individual website to ask for your permission.